Discussion:
CSSMTP Startup Failure
(too old to reply)
Vinson Lee
2017-06-06 18:57:15 UTC
Permalink
Raw Message
We're still on z/OS 1.13 and just IPL'ed. The CSSMTP started task won't come up and we're getting this:

EZD1807I CSSMTP ERROR IN INITIALIZATION : CONFIGURATION FILE ERRORS

We also see this in the log:

CSSMTP INFO :001:mlCfgOpenSocket:IPv4 socket successfully open/closed
CSSMTP DEBUG :001:mlIconvTest:CUNLINFO error 8:11
CSSMTP ERROR :001:mlIconvTest:Tests for codepage 'IBM-1047' failed. Unicode services are not available (2)
CSSMTP ERROR :001:mlIconvTest:LE function CUNLINFO failed: EDC5262I An iconv() function encountered an unexpected error while using Unicode Services. (errno2=0x0000050A)
CSSMTP ERROR :001:mlCfgOperCmd:'IBM-1047' is not a valid code page for 'CSSMTP_CODEPAGE_CONFIG'


Don't recall having to do anything specific for Unicode and my research shows the IBM-1047 codepage should be available by default. A display shows this

D UNI,ALL
CUN3000I 11.47.46 UNI DISPLAY 242
ENVIRONMENT: CREATED 06/06/2017 AT 11.06.21
MODIFIED 06/06/2017 AT 11.14.12
IMAGE CREATED --/--/---- AT --.--.--
SERVICE: CHARACTER CASE NORMALIZATION COLLATION
STRINGPREP BIDI CONVERSION INF
STORAGE: ACTIVE 89 PAGES
FIXED 0 PAGES
LIMIT 524287 PAGES
CASECONV: DISABLED
CASE VER: NONE
NORMALIZE: DISABLED
NORM VER: NONE
COLLATE: DISABLED
COLL RULES: NONE
STRPROFILES: NONE
CONVERSION: 01200(13488)-00037-E 01208-00037-E
00037-00367-E 00037-01208-R
00367-00037-E 00037-01200(13488)-R
00819-01047-L 00819-01047-R
01047-00819-L 01047-00819-R
01047-00850-R 01047-00850-C


Anyone come across this problem before? Any suggestions on what to do?

Thanks in advance.

Vince

----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Lizette Koehler
2017-06-06 19:57:26 UTC
Permalink
Raw Message
If you do not get an good answers,

You might try joining the TCPIP list and ask there as well

TCPIP To subscribe, send mail to ***@VM.MARIST.EDU with the command (paste it!) in the e-mail message body:
SUBSCRIBE IBMTCP-L

Or this url and go to the bottom of the webpage: http://www2.marist.edu/htbin/wlvindex?IBMTCP-L

Lizette
-----Original Message-----
Behalf Of Vinson Lee
Sent: Tuesday, June 06, 2017 11:58 AM
Subject: CSSMTP Startup Failure
We're still on z/OS 1.13 and just IPL'ed. The CSSMTP started task won't come
EZD1807I CSSMTP ERROR IN INITIALIZATION : CONFIGURATION FILE ERRORS
CSSMTP INFO :001:mlCfgOpenSocket:IPv4 socket successfully open/closed
CSSMTP DEBUG :001:mlIconvTest:CUNLINFO error 8:11
CSSMTP ERROR :001:mlIconvTest:Tests for codepage 'IBM-1047' failed. Unicode
services are not available (2)
CSSMTP ERROR :001:mlIconvTest:LE function CUNLINFO failed: EDC5262I An
iconv() function encountered an unexpected error while using Unicode
Services. (errno2=0x0000050A)
CSSMTP ERROR :001:mlCfgOperCmd:'IBM-1047' is not a valid code page for
'CSSMTP_CODEPAGE_CONFIG'
Don't recall having to do anything specific for Unicode and my research shows
the IBM-1047 codepage should be available by default. A display shows this
D UNI,ALL
CUN3000I 11.47.46 UNI DISPLAY 242
ENVIRONMENT: CREATED 06/06/2017 AT 11.06.21
MODIFIED 06/06/2017 AT 11.14.12
IMAGE CREATED --/--/---- AT --.--.--
SERVICE: CHARACTER CASE NORMALIZATION COLLATION
STRINGPREP BIDI CONVERSION INF
STORAGE: ACTIVE 89 PAGES
FIXED 0 PAGES
LIMIT 524287 PAGES
CASECONV: DISABLED
CASE VER: NONE
NORMALIZE: DISABLED
NORM VER: NONE
COLLATE: DISABLED
COLL RULES: NONE
STRPROFILES: NONE
CONVERSION: 01200(13488)-00037-E 01208-00037-E
00037-00367-E 00037-01208-R
00367-00037-E 00037-01200(13488)-R
00819-01047-L 00819-01047-R
01047-00819-L 01047-00819-R
01047-00850-R 01047-00850-C
Anyone come across this problem before? Any suggestions on what to do?
Thanks in advance.
Vince
----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Gibney, Dave
2017-06-06 20:06:25 UTC
Permalink
Raw Message
Look further back in the IPL SYSLOG and confirm that UNICODE services were successfully initialized.
-----Original Message-----
On Behalf Of Lizette Koehler
Sent: Tuesday, June 06, 2017 12:58 PM
Subject: Re: CSSMTP Startup Failure
If you do not get an good answers,
You might try joining the TCPIP list and ask there as well
SUBSCRIBE IBMTCP-L
https://urldefense.proofpoint.com/v2/url?u=http-
3A__www2.marist.edu_htbin_wlvindex-3FIBMTCP-
2DL&d=DwIFaQ&c=C3yme8gMkxg_ihJNXS06ZyWk4EJm8LdrrvxQb-
Je7sw&r=u9g8rUevBoyCPAdo5sWE9w&m=GVEWkEr1E-
ta77bNhuAyl_10bJgNt7yo1rFNQzaMvOo&s=1fx9xhF8CXq6Np234FZufjDkvLo
bzUze0VYmPuVlKdc&e=
Lizette
-----Original Message-----
On Behalf Of Vinson Lee
Sent: Tuesday, June 06, 2017 11:58 AM
Subject: CSSMTP Startup Failure
We're still on z/OS 1.13 and just IPL'ed. The CSSMTP started task
EZD1807I CSSMTP ERROR IN INITIALIZATION : CONFIGURATION FILE ERRORS
CSSMTP INFO :001:mlCfgOpenSocket:IPv4 socket successfully
open/closed
CSSMTP DEBUG :001:mlIconvTest:CUNLINFO error 8:11 CSSMTP ERROR
:001:mlIconvTest:Tests for codepage 'IBM-1047' failed. Unicode
services are not available (2) CSSMTP ERROR :001:mlIconvTest:LE
function CUNLINFO failed: EDC5262I An
iconv() function encountered an unexpected error while using Unicode
Services. (errno2=0x0000050A) CSSMTP ERROR
:001:mlCfgOperCmd:'IBM-1047' is not a valid code page for
'CSSMTP_CODEPAGE_CONFIG'
Don't recall having to do anything specific for Unicode and my
research shows the IBM-1047 codepage should be available by default.
A display shows this
D UNI,ALL
CUN3000I 11.47.46 UNI DISPLAY 242
ENVIRONMENT: CREATED 06/06/2017 AT 11.06.21
MODIFIED 06/06/2017 AT 11.14.12
IMAGE CREATED --/--/---- AT --.--.--
SERVICE: CHARACTER CASE NORMALIZATION COLLATION
STRINGPREP BIDI CONVERSION INF
STORAGE: ACTIVE 89 PAGES
FIXED 0 PAGES
LIMIT 524287 PAGES
CASECONV: DISABLED
CASE VER: NONE
NORMALIZE: DISABLED
NORM VER: NONE
COLLATE: DISABLED
COLL RULES: NONE
STRPROFILES: NONE
CONVERSION: 01200(13488)-00037-E 01208-00037-E
00037-00367-E 00037-01208-R
00367-00037-E 00037-01200(13488)-R
00819-01047-L 00819-01047-R
01047-00819-L 01047-00819-R
01047-00850-R 01047-00850-C
Anyone come across this problem before? Any suggestions on what to do?
Thanks in advance.
Vince
----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions, send email to
----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Gord Tomlin
2017-06-06 20:09:21 UTC
Permalink
Raw Message
Post by Vinson Lee
EZD1807I CSSMTP ERROR IN INITIALIZATION : CONFIGURATION FILE ERRORS
CSSMTP INFO :001:mlCfgOpenSocket:IPv4 socket successfully open/closed
CSSMTP DEBUG :001:mlIconvTest:CUNLINFO error 8:11
CSSMTP ERROR :001:mlIconvTest:Tests for codepage 'IBM-1047' failed. Unicode services are not available (2)
CSSMTP ERROR :001:mlIconvTest:LE function CUNLINFO failed: EDC5262I An iconv() function encountered an unexpected error while using Unicode Services. (errno2=0x0000050A)
CSSMTP ERROR :001:mlCfgOperCmd:'IBM-1047' is not a valid code page for 'CSSMTP_CODEPAGE_CONFIG'
Don't recall having to do anything specific for Unicode and my research shows the IBM-1047 codepage should be available by default. A display shows this
D UNI,ALL
CUN3000I 11.47.46 UNI DISPLAY 242
ENVIRONMENT: CREATED 06/06/2017 AT 11.06.21
MODIFIED 06/06/2017 AT 11.14.12
IMAGE CREATED --/--/---- AT --.--.--
SERVICE: CHARACTER CASE NORMALIZATION COLLATION
STRINGPREP BIDI CONVERSION INF
STORAGE: ACTIVE 89 PAGES
FIXED 0 PAGES
LIMIT 524287 PAGES
CASECONV: DISABLED
CASE VER: NONE
NORMALIZE: DISABLED
NORM VER: NONE
COLLATE: DISABLED
COLL RULES: NONE
STRPROFILES: NONE
CONVERSION: 01200(13488)-00037-E 01208-00037-E
00037-00367-E 00037-01208-R
00367-00037-E 00037-01200(13488)-R
00819-01047-L 00819-01047-R
01047-00819-L 01047-00819-R
01047-00850-R 01047-00850-C
Anyone come across this problem before? Any suggestions on what to do?
Thanks in advance.
Vince
This looks suspiciously like the symptoms of OA48941:

http://www-01.ibm.com/support/docview.wss?uid=isg1OA48941

You might want to see whether the associated PTF is applied.

--

Regards, Gord Tomlin
Action Software International
(a division of Mazda Computer Corporation)
Tel: (905) 470-7113, Fax: (905) 470-6507

----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Jesse 1 Robinson
2017-06-06 21:38:20 UTC
Permalink
Raw Message
That APAR may look enticing, but it's pretty unlikely. Some data/time field in Unicode turned all zero in late 2015. Anyone who IPLed after that moment in time would get Unicode initialization failure. I doubt that OP has avoided IPL all this time unless it's a very infrequently used LPAR.

.
.
J.O.Skip Robinson
Southern California Edison Company
Electric Dragon Team Paddler
SHARE MVS Program Co-Manager
323-715-0595 Mobile
626-543-6132 Office ⇐=== NEW
***@sce.com


-----Original Message-----
From: IBM Mainframe Discussion List [mailto:IBM-***@LISTSERV.UA.EDU] On Behalf Of Gord Tomlin
Sent: Tuesday, June 06, 2017 1:10 PM
To: IBM-***@LISTSERV.UA.EDU
Subject: (External):Re: CSSMTP Startup Failure
Post by Vinson Lee
EZD1807I CSSMTP ERROR IN INITIALIZATION : CONFIGURATION FILE ERRORS
CSSMTP INFO :001:mlCfgOpenSocket:IPv4 socket successfully open/closed
CSSMTP DEBUG :001:mlIconvTest:CUNLINFO error 8:11 CSSMTP ERROR
:001:mlIconvTest:Tests for codepage 'IBM-1047' failed. Unicode
services are not available (2) CSSMTP ERROR :001:mlIconvTest:LE
function CUNLINFO failed: EDC5262I An iconv() function encountered an unexpected error while using Unicode Services. (errno2=0x0000050A) CSSMTP ERROR :001:mlCfgOperCmd:'IBM-1047' is not a valid code page for 'CSSMTP_CODEPAGE_CONFIG'
Don't recall having to do anything specific for Unicode and my
research shows the IBM-1047 codepage should be available by default.
A display shows this
D UNI,ALL
CUN3000I 11.47.46 UNI DISPLAY 242
ENVIRONMENT: CREATED 06/06/2017 AT 11.06.21
MODIFIED 06/06/2017 AT 11.14.12
IMAGE CREATED --/--/---- AT --.--.--
SERVICE: CHARACTER CASE NORMALIZATION COLLATION
STRINGPREP BIDI CONVERSION INF
STORAGE: ACTIVE 89 PAGES
FIXED 0 PAGES
LIMIT 524287 PAGES
CASECONV: DISABLED
CASE VER: NONE
NORMALIZE: DISABLED
NORM VER: NONE
COLLATE: DISABLED
COLL RULES: NONE
STRPROFILES: NONE
CONVERSION: 01200(13488)-00037-E 01208-00037-E
00037-00367-E 00037-01208-R
00367-00037-E 00037-01200(13488)-R
00819-01047-L 00819-01047-R
01047-00819-L 01047-00819-R
01047-00850-R 01047-00850-C
Anyone come across this problem before? Any suggestions on what to do?
Thanks in advance.
Vince
This looks suspiciously like the symptoms of OA48941:

http://www-01.ibm.com/support/docview.wss?uid=isg1OA48941

You might want to see whether the associated PTF is applied.

--

Regards, Gord Tomlin
Action Software International
(a division of Mazda Computer Corporation)
Tel: (905) 470-7113, Fax: (905) 470-6507


----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Tony Harminc
2017-06-06 22:50:17 UTC
Permalink
Raw Message
Post by Jesse 1 Robinson
That APAR may look enticing, but it's pretty unlikely. Some data/time field in Unicode turned all zero in late 2015. Anyone who IPLed after
that moment in time would get Unicode initialization failure. I doubt that OP has avoided IPL all this time unless it's a very infrequently used
LPAR.
I don't think the entirety of Unicode services fails to initialize.
Rather, callers of the conversion information service CUNLINFO will
fail. Those who just use the conversion services will work OK until
z/OS 2.1. The symptoms otherwise match perfectly (rc 08/0B). Is it
possible that CSSMTP was updated some time before the IPL, and is now
using CUNLINFO where it previously did not?

The quick and definitive test is in the APAR: look at the (former)
timestamp field in the UCCB. Easily done with IPCS or TSO TEST or
ISPF, e.g. in ISPF type DDLIST, then br 10.?+220?+3C?+10

The first 8 bytes should be 0's. If they look like a TOD clock from
around the time you IPL'd, then this is your problem. Unexplained is
why it surfaced only now.

Tony H.

----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Vinson Lee
2017-06-07 00:51:52 UTC
Permalink
Raw Message
Thanks to all who responded. It was indeed Apar OA48941 for Unicode services. I found it doing a Google search before getting back to the listserv. I have applied the fix to our Test LPAR and CSSMTP will now start correctly. Prior to last Sunday, we had not IPL'ed our production LPAR since 12/14/2014. We've been busy moving to a new PeopleSoft system and have not been keeping the mainframe up to date. :( We don't really need to do IPLs even for time changes anymore.

Thanks again guys!

Vince

----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Vinson Lee
2017-06-07 00:56:43 UTC
Permalink
Raw Message
And gals too. You know what I mean. :)

----------------------------------------------------------------------
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to ***@listserv.ua.edu with the message: INFO IBM-MAIN
Loading...